0251 / 590 837 15
info@a-coding-project.de
;

Konfigurieren von WYSIWYG

Code & Blog Logo

Code & Blog Logo

Im letzten Artikel der Aktion Eigenes CMS wurde das WYSIWYG eingebaut. Dieses wurde allerdings noch nicht komplett konfiguriert. Zum einen muss noch das ganze auf Deutsch übersetzt werden und zum anderen funktioniert die Rechtschreibüberprüfung noch nicht.

Fangen wir mal mit der Rechtschreibprüfung an. Hierzu muss das PHP Spellchecker(steht ganz unten auf der Seite) herunter geladen werden. Das ganze muss dann in dem Ordner /system/WYSIWYG/plugins entpackt werden. Das war auch schon. Nun kannst du im Admin-Bereich prüfen, ob es auch funktioniert.

Weiter gehts mit der Deutschen Sprache. Dafür muss als erstes das deutsch LanguagePack(anharken und unten auf Download gehen) in den Ordner /system/WYSIWYG/ entpackt werden.

Danach muss noch in der Datei /admin/includes/site-edit.php der das Language gesetzt werden:

tinyMCE.init({
// General options
language : „de“,
mode : „textareas“,
theme : „advanced“,

Das wars auch schon für heute. Demnächst geht es dann weiter mit dem Speichern.

Kommentare

m1staX schrieb am 23.09.2011:

Habe ein gelöstes Problem zu berichten... Beim Aufruf der Rechtschreibprüfung bekam ich die die Fehlermeldung: Error response: <b>Warning</b>: fsockopen() [<a href='function.fsockopen' rel="nofollow">function.fsockopen</a>]: unable to connect to ssl://www.google.com:443 (Unable to find the socket transport &quot;ssl&quot; - did you forget to enable it when you configured PHP?) in <b>D:devxampphtdocscmssystemWYSIWYGpluginsspellcheckerclassesGoogleSpell.php</b> on line <b>85</b> Could not open SSL connection to google.{"id":null,"result":[],"error":null} Die Lösung hab ich hier gefunden: http://boshdirect.com/blogs/tech/google-spellcheck.html In der php.ini müsst ihr die Zeile extension=php_curl.dll aktivieren!

m1staX schrieb am 23.09.2011:

PS: Ich verwende die Standard-Konfiguaration von XAMPP

Julian schrieb am 26.12.2011:

Habe da mal eine Frage: Wenn ich in das Editorfeld einen Submit Button einfüge, und anschließend auf speichern klicke, passiert etwas Komisches: Der Submitbutton verschiebt sich unter das Editorfenster und der eigentliche Speichernbutton verliert seine Funktion. Das Speichern solcher Inhalte wird dadurch unmöglich :/ Gibt es da was in der Konfiguration von TinyMCE zu machen? Oder muss man den ausgelesenen Quellcode maskieren o.Ä.? Danke für jede Hilfe!